Closure require

closure require

Плагин для продуктов JetBrains.

Расставляет Googlr Closure require для использованных API.

Из минусов:

  1. в WEBStorm и PHPStorm не работает функция хот фикса
  2. Просто генерит goog.require(«…»); не заботясь о том, что скажет Closure Linter (т.е. двойные кавычки и не алфавитный порядок)
  3. Цепляется ко всем классам подряд…
  4. если у объекта длинное имя (т.е. он где-то в глубине иерархии name space) и приходится писать вызов объекта в две строчки «хавает» только первую строку
  5. По аналогии с выше перечисленным цепляется к имени template из soy фаила

Добавить комментарий

Ваш адрес email не будет опубликован.